Supported browsers in dotmailer - Internet Explorer 8 unsupported from April 2016

As of 1 April 2016 dotmailer will no longer be supported in Internet Explorer 8 (IE8). If you are using it then it may be time to upgrade to the latest version.

dotmailer will, almost certainly, continue to work in IE8 for a short while, but this news means that when we release new features, or make changes to the platform, we will no longer guarantee that it will work.

If you are unsure what version of Internet Explorer you are using, you can visit this page on Microsoft's website to find out.

For guaranteed support for all our features, users should upgrade to a more up-to-date version of Internet Explorer. Or, if you prefer, download and install one of our other supported browsers such as Chrome or Firefox.  You can find an up-to-date list of our supported browsers in the dotmailer knowledge base.

Have more questions? Submit a request

Comments